No available links to pdf for zotero

amadieu 6 aastat tagasi uuendaja Adam Rego Johnson 2 aastat tagasi 12


Thanks a lot for Bibbase which is a wonderful handy tool for displaying references. I use zotero and I generated a page for my publications. Everything works fine, except that there are no links to the online pdf of my papers that are available in Zotero. I know that with Mendeley it works, but I did not find out why it is not possible with zotero. here is my bibbase page : https://bibbase.org/show?bib=https%3A%2F%2Fapi.zotero.org%2Fusers%2F4775684%2Fcollections%2FE39GJDNG%2Fitems%3Fkey%3D7h3Yg7Te1gv7hGDrarObACo1%26format%3Dbibtex%26limit%3D100&msg=embed#

How could add the links to the pdf files?

Thanks in advance for your help.


Franck Amadieu

Otsin vastust

Hi Franck,

I'm surprised to see that, too. This used to work. It might be related to Zotero's ongoing transition to Zotero 5.0 (as they note here https://www.zotero.org/support/dev/web_api/v3/types_and_fields).

I will see whether this can be re-enabled using this feature of their API https://www.zotero.org/support/dev/web_api/v3/fulltext_content.


That would be great! Thanks for BibBase!

Any update on this?  Still no pdfs through Zotero public groups. 

Hi, are there any updates to this issue? I am attempting to transfer my organization's BibBase page from one connected to a Mendeley library to one connected to the same library in Zotero. While the PDFs are linked to on the BibBase page connected to Mendeley, the same PDFs (only this time hosted on Zotero's cloud storage instead of Mendeley's) attached to the same references are not available on my new BibBase page linked to a Zotero library. The only occasional PDF attachments that come up are when the URL included to the BibTeX is linking directly to an online PDF. It is not pulling any of the PDFs from Zotero.

Thank you so much for all your work.

I've investigated this more. The fulltext feature Zotero describes in the link I posted doesn't seem to work very well. When I try it on a group with an item that has an attached PDF, I get "{}" (i.e., it doesn't find any). If I try it on your group I get:

> curl https://api.zotero.org/groups/4501563/fulltext


This is probably because your group is not public. We could try again after you make it "public closed", but so far this doesn't look promising.

Hi Christian,

Thank you so much for investigating this more.

You may have already put it together, but the characters on the page you linked looks to me like the codes Zotero uses to store each PDF. Zotero's internal directory for PDFs seems to store local PDFs in individual folders with the same length string. I can confirm that I looked up some files and they do seem to match that page, and the number of unique strings on that page seems to correlate with the number of PDFs in the group library (it has 580, though on my library I'm counting 581 actually).

I have changed the group to public closed as of a few hours ago. I misunderstood Zotero's restrictions and thought group file storage was only enabled on private groups, but it does include public closed groups, which I probably should have used to begin with in case it disabled access from BibBase. Hopefully that's just a silly mistake that fixes the issue, however, I have not seen any change on my linked BibBase page regarding PDFs since changing the group status. But I have also not seen it update a change to a citation I have tried to make in my Zotero group library, so the BibBase page could just be very slow to update right now or stuck for some reason.

Thanks for changing your group settings. I was now able to find the "fulltext"s for your group library, however when I retrieve them they are just text (not PDF), e.g.:

> curl https://api.zotero.org/groups/4501563/items/KJVQ337I/fulltext | head
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0{
"content": "IFN Working Paper No. 1088, 2015\nThe National Wealth of Sweden, 1810–2014 Daniel Waldenström\nResearch Institute of Industrial Economics P.O. Box 55665\nSE-102 15 Stockholm, Sweden info@ifn.se www.ifn.se\n\nThe National Wealth of Sweden, 1810–2014*\nDaniel Waldenström† Uppsala University, IZA, CEPR and IFN\nSeptember 29, 2015\nAbstract This study presents a new database, the Swedish National Wealth Database (SNWD), which contains annual data on pr

So this doesn't really solve this problem, the PDFs added to Zotero are still not exposed by their API this way.

I see, thank you. That's too bad. So, then, it doesn't appear that this is something that you can fix on your side, and is seemingly just an issue with Zotero's API?


Yes, it's on their end. Without them exposing this information in some way, we won't be able to display it. But you always have the option to use a shared Zotero account of which you can import the "My Library" into BibBase -- that will include pdf links. That said, bibtex files, either self-hosted, on github, or directly on BibBase, is always the most versatile option.

Thank you for the clarification and explanation. I have tried using a shared Zotero account as an alternative like you mentioned, but I have been unable to get its PDFs to come through BibBase either -- do you know what could be causing the issue?

I've copied a portion of the shared group library to the personal library, and as far as I can tell I've verified that all the files have synced to Zotero's servers (I have also waited a few hours). I have the PDF files stored locally on my computer, they are duplicated from the group library and do not simply link to the same PDF files in case that could cause any issue. I have also added a totally new attachment (Setha Low's "Spatializing Culture" article) to see if that somehow is different, but this does not link to a PDF nor does it lead (at least yet?) to a proper BibBase publication link, returning a 404. The files should all be synced -- they are accessible on Zotero's web library and I can see that they have counted against my file storage. I'm not sure what could be causing an issue here. Here is the link to the BibBase page for the new personal library:  https://bibbase.org/show?bib=https://bibbase.org/zotero/GCWealthProject#

Thank you.

EDIT: I should also note that I have created this personal library using a secondary profile on the Zotero desktop app in order to retain my personal Zotero account with its data syncing as well as this Zotero account used for work. Prior I never needed to have the account actually synced to any computer as it just hosted the group which I could access from my personal Zotero account. This results in the data directory pointing elsewhere, not to the default path (in C:\Users\<username>\AppData\Roaming\Zotero\Zotero\Profiles\<profilename>\zotero\storage rather than the default C:\Users\<username>\Zotero\storage. I'm not sure if this would impact anything, as like I said it seems like the files are syncing to Zotero just fine, but I figured I might mention it.

Hello, are there any updates you can share with me here? Thank you so much.


Nevermind this, no worries. We've decided to pursue manual uploads with PDFs hosted on BibBase instead for greater control. Thanks for all your help.