+1
Fixed

Multiple entries with same title and same year are displayed as duplicates

Joachim Staib 10 jaar geleden bijgewerkt door Prof Chaos 3 week geleden 8
Hi,

thanks for this great service. There seems to be a small bug. When you have two entries with the same title and the same year, both entries are shown with identical data.
Example:
@techreport{TechReport1
author = {John McBug},
institution = {ACME},
title = {DemoPaper: A Title about nothing},
year = {2012},
}

@article{Article1
author = {John McBug},
journal = {Another Journal},
title = {DemoPaper: A Title about nothing},
YEAR = {2012},
}

This will show the entry "DemoPaper: A Title about nothing. McBug, J. Another Journal, . 2012." twice, instead of showing the data of the techreport in the first entry. We are using bibbase at our university chair where it is sometimes the case that a paper is submitted as technical report and then later submitted as an article with the same name.

A quick workaround for this is to make the titles different, for example by replacing one space in the title by a nbsp;

Regards
Joachim

I have the same problem -- and it cost me about 2 hours of checking untl I figured out the problem! (I.e., until I found out which of my publications was not showing). So I am also interested in having this fixed.


Another reason why that problem appears in practice: Very often one gives a paper to a *workshop* to get additional feedback. Sometimes, depending on the timing, one gets the approved version (but with the same title) accepted at a conference in the same year!

This happened to me. The papers are only sligthly different, but the order of the authors got changed. Yet, only one of them is listed (the workshop, not the conference).

Please fix! :)

+1
Fixed

This bug has finally been fixed.

@techreport{TechReport1,
author = {John McBug},
institution = {ACME},
title = {DemoPaper: A Title about nothing},
year = {2012}
}

@article{Article1,
author = {John McBug},
journal = {Another Journal},
title = {DemoPaper: A Title about nothing},
YEAR = {2012}
}

will now show as:

Prof. Chaos: please let me know if you still see the problem and if so, please send me the bibtex to reproduce it.


Thanks for your patience!

Works now, thank you a lot!

Dear Fritz,

Wow, that was already fixed 4 years ago! Such a long time... Thank you once more anyway. :)

It seems however that the bug was either re-introduced or persisted but was never discovered. So I have two cases where this problem still occurs. (Just some background: previously I had all my publications separated into different files and so those entries where the issue now becomes visible were never in the same file and bib list -- but now they are.)


// I was too lazy to make it anonymous; I don't see the point anyway. :)

@techreport{Bercher2008FONDPGHeuristicTR,

author = {Pascal Bercher and Robert Mattm{\"u}ller},
title = {A Planning Graph Heuristic for Forward-Chaining Adversarial Planning},
...}
and
@InProceedings{Bercher2008FONDPGHeuristic,
author = {Pascal Bercher and Robert Mattm{\"u}ller},
title = {A Planning Graph Heuristic for Forward-Chaining Adversarial Planning}, booktitle = {Proceedings of the 18th European Conference on Artificial Intelligence ({ECAI} 2008)},
...
}

In the list, bith entries are however shown identically; it uses the one from the TR.


The same issue happens with the two papers with keys Johnson2022aSATPruning and Johnson2022bSATPruning (from 2022).


You can verify this by taking a look at:
https://bercher.net/my-publications/all-publications

You can access the bibfile on:
https://bercher.net/bibtex/bibliography.bib

Thank you again! :) 

I just realized that I used your last name.^^ Sorry for that.^^ Why can't we edit old posts? That's odd! We can't even delete an entry... That is super odd! What if somebody accidentally posts sensitive information? Or am I just not finding the right button?

I can delete posts, and sometimes have to when spammers show up. So if you ever need one deleted, just let me know.

Re. your question: they show up as different entries for me:

Image 178

Re you can edit: Yeah... Still seems easier to allow editing by the authors. (Though I noticed that we *can* -- it seems that it only gets deactivated after a time, so one has a short timewindow to make edits; which seems okay.)

Re you see two different entries: Wow! What the hell. :) Below what I see:

Image 179

Ahhhh, interesting! I see what you see if I simply scroll down to that year. But if I use the *search* function (e.g., type "mattm"), then I get this duplicate! So it's a bug in the search function. Should I post another post to report this since this is technically a different bug?

Debugging is fun! Here some further observations:
- the very same bug is responsible for the duplication of the "Johnson" entry (see above). For example, search for "john" and you get two identical entries. Just scroll down to that year and you have the two different one. (But see the next point first)
- once you searched you already corrupted the list. I.e., if you refresh and hence see the correct list, all is good. If you search you get, as said, the duplicates. However, if you then delete the search again to see the entire list it remains broken. I.e., even then you see duplicates (although the search is empty)
- also note that it does not matter what you search for; the list remains broken. I.e., you can even search for 2024 (which doesn't have problematic entries), and then delete that search again. Afterwards, you still get the duplicates (in the full list; look for 2022 and 2008).


Thus, in conclusion: the "search filter" corrupts the list by creating duplicates where authors and title are identical.


Again, let me know if I should just re-post this under a new thread (since it's a different bug), then you can document it as "under review".

Anyway, thanks for being so quick!