0
En revisión

Caching problem `nocache`

Kenneth hace 4 años actualizado por Christian Fritz hace 5 meses 3

I have a cashing problem of some sort. If I use the following bib file then it renders like described in this (http://bibbase.userecho.com/topics/148-parser-issue-if-the-key-contain-ampersand/) previous issue:

http://bibbase.org/show?bib=blog.lausdahl.com/wp-content/uploads/publications/lausdahl.bib&proxy=1&groupby=year

```

undefined (9)

. In .
bibtex 1 download
. In .
bibtex 1 download
. .
bibtex 1 download
. In .
bibtex 1 download
. In .
bibtex 1 download
. In .
bibtex 1 download
. In .
bibtex 1 download
. .
bibtex 1 download
. In .
bibtex 1 download
```

but if I add either `&nocache=1` or `&nocache=0` then it renders correctly. Any idea why this is happening. I assume that `&nocache=1` should be avoided since you probably try to reduce processing by caching the data.

Iniciado

Hi Kenneth,


Thank you so much for reporting this. It allowed me to discover a bug in our caching logic! When using nocache the cache was bypassed but a new cache entry was created (rather then the old one updated). So probably at one point there was a broken bib file and the page was loaded with nocache, and every since the cache was referring to that.


I've cleared the cache and the page is fine again now. We'll also get that bug fixed right away.


Thanks again!


Hello, 

We are also running into the same problem with caching, where even if we set nocache=1, bibbase seems to be working with a cached version of the bib file.

For example, if you try 

https://bibbase.org/show?bib=https%3A%2F%2Fresearch.seas.ucla.edu%2Farni%2Ffiles%2F2019%2F08%2Farni_db.bib&msg=embed&authorFirst=1&nocache=1

then you see that bibbase is throwing a warning due to a missed "comma" in the bib file. However, if you try to follow the bib file link https://research.seas.ucla.edu/arni/files/2019/08/arni_db.bib, you will see that the file actually already have that fixed. 

Can you please help me understand this caching issue ?

En revisión

Hi Yahya,

When I fetch the URL of your bibtex file I get this redirect response with a cache control line. I can't say for sure, but I suspect that's where things are being cached.

> curl -i <a href="https://research.seas.ucla.edu/arni/files/2019/08/arni_db.bib" class="redactor-autoparser-object">https://research.seas.ucla.edu/arni/files/2019/08/arni_db.bib</a>
HTTP/2 302 
server: openresty
date: Tue, 01 Dec 2020 17:40:45 GMT
content-type: image/bib
location: <a href="https://cpb-us-w2.wpmucdn.com/research.seas.ucla.edu/dist/3/23/files/2019/08/arni_db.bib" class="redactor-autoparser-object">https://cpb-us-w2.wpmucdn.com/research.seas.ucla.edu/dist/3/23/files/2019/08/arni_db.bib</a>
cache-control: public, max-age=31536000
etag: 53fac6d6bed1e03f4313341be5aedf76
x-robots-tag: noindex, nofollow
x-cache: BYPASS
x-cache-bypass-reason: Arguments found


Even after deleting that bibtex file manually from BibBase's cache, the result is still the same, meaning the server that is serving the file (the one that bibbase is redirected to), still serves the cached file when bibbase is requesting it. I assume that is a policy by this host, which seems to be a wordpress provider, can that be?


This issue should resolve itself eventually when the cache of your host expires. Alternatively you could use a different server to host your bibtex file, or sign up for one of our premium plans and store your file on bibbase.org directly, if that's an option for your group.