BibBase not loading all my citations (personal library, public profile, ~500 citations)

Huong Le hace 3 años actualizado hace 3 años 5

Hi all,

My use case is very simple: I have a personal library in Zotero (~500 citations) and I want to embed it all on my personal site. Here is what I've tried so far:

(1) Click on the "BibBase page of entire library" to embed the whole library. It gives the error "BibBase: Error retrieving bibtex file.". If I click on "this bibtex file", it shows "The Zotero user you specified could not be found."

(2) Create a collection that contains all my citations in My library (very silly yeah). Embed this collection only in my site. It works, but shows only ~100 citations (I've read somewhere that this was indeed an issue with Zotero, but it was fixed).

For information, I don't belong to any group. My Zotero library is set to public (I just don't share the notes). I see that the API key of Bibbase is correctly added in my Zotero profile. I don't sync attachments to Zotero. My storage doesn't exceed the limit of 300MB by Zotero. 

I want to have my full citation displayed instead of being limited to 100. Could anyone help me with this please?

Thanks very much in advance!

En revisión

Hi Huong,

I've looked at your account but I don't see any Zotero credentials on it. What happens when you click this link: https://bibbase.org/service/zotero ? Could you send me a screenshot of what you see after you click that?



Hi Christian,

Thank you so much for your reply! This is what I see when I click your link:

(the collections 2020, 2021, 2022 are my desperate attempts to make all my article shown in the embedding, but the collection I want to embed is the "PhD" one)


Thanks. From the picture I was able to see that this is using a different account from the one under your name. Looking at that other account I found the problem. It was actually a bug on our end, regarding a corner-case in the zotero workflow. This is fixed now and your library now shows up:


(no need to use a collection)

Thanks for reporting this!


Now it works like a charm! Thank you very much for your help :-) !!!