Embedding issues

Melissa 7 years ago updated by Christian Fritz 5 years ago 2

I have tried all the methods of embedding on my wordpress site and they all return blank - no error, just blank.  The only thing I can do is use an iframe directly to the bib (http://bibbase.org/show?bib=https%3A%2F%2Fapi.zotero.org%2Fgroups%2F679474%2Fitems%3Fkey%3DSXBLN104gwrkcG71MkWevFEP%26format%3Dbibtex%26limit%3D100#).  

It is a Zotero group and I have been trying to embed it using script or php, defaulting to keywords.  Even in the iframe, it doesn't seem to be showing all the entries.  

I also tried using the link with username and groupname and it also was blank. 

The page is here: http://romanistudies.net/bibliography/open-bib/

any advice would be very much appreciated!!

I have the same issue. 

Trying to embed

<script src="https://bibbase.org/show?bib=https%3A%2F%2Fapi.zotero.org%2Fgroups%2F2298129%2Fitems%3Fkey%3DDi2aUrSQXpXlWmYdUvNGDXyv%26format%3Dbibtex%26limit%3D100&jsonp=1"></script>
And it doesn't work. 

This is a group in Zotero. I've also tried a collection, with no succes. 

I've deactivated the ad blocker in my browser, just in case... 

Could there be a conflict with another WP plugin?


There is nothing we can do from the BibBase side on this. This is a restriction from Wordpress. Same web hosts, incl. also Google Sites, just don't allow embedding script tags. The only embedding option with those is usually iframes (if those are allowed), but that's not a good option.

We always recommend hosting your own page yourself (if necessary via Github pages, you can just fork our example), using a bibtex file as source (although Zotero is a decent option, too), and embed using the script tag. This combination give you the most control.