0
Answered

Accents parsing

Eliseo Ferrante 7 years ago updated by Tony 1 year ago 9
Hi and thank you for your amazing work. I have a problem, but I'm not understanding whether I'm doing something wrong myself or not.

None of the accents in my bib are visualizing correctly with bibbase.

http://www.bibbase.org/show?bib=http://iridia.ulb....

Example: Decugni\`ere -> DecugniÌ€ere instead of Decugnière

I also notice weird characters also where I do not use special commands. What can I be doing wrong? Latex generates perfect documents using that bibtex file.

Thanks for the help!

Eliseo
Sorry the link didn't copy correctly

http://www.bibbase.org/show?bib=http://iridia.ulb....

The bib is here: http://iridia.ulb.ac.be/~eferrante/publications.bib
Eliseo: it looks fine to me (see screenshot below). What most probably is happening is that you are nor using unicode (utf-8) as your character encoding in your browser, or the font you are using as your default fault in your browser simply doesn't support utf-8.



In Chrome you can change the font and encoding in the advanced settings:



BTW, when you are embedding this page into your homepage then this problem might go away all by itself, since you are probably specifying the character coding as utf-8 in your homepage already. This is set in the head of the html. BibBase pages don't have a head, so that they can be embedded easily. But this headlessness also means that I can't set the encoding in the bibbase page itself.
Dear Christian Fritz,

thank you for your very useful answer. Indeed, changing the setting in the browser works, but this seems to be needed in all browser because by default utf-8 is not selected (I had Western ISO-88-59-1). I will try to embed it in my cms then, to avoid this issue.

Maybe, as a feature request, one can have an option that allow to select whether to include or not the html head when generating the bibbase page? (If that makes sense :-) ).

Thanks again!!!

Eliseo
I just posted a similar question.    I solved the problem by putting the title in question into HTML  instead of UTF-8.   Of course that won't work when processing the BibTeX file in TeX, so it's a bit of a hack, in that I'll have to maintain the bibtex file on my server by hand.
The recommended way to solve this problem is to set the charset of the page to utf-8, e.g., using the following meta tag in the HTML head:

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">



Thanks! I did solve the problem a while ago in the way you suggested or similar, but had to invent a workaround for the fact I didn't have direct control on the HTML head. 

I am having a similar problem.  See https://academic.mu.edu/peressini/afp_pubs.php.  Two entries under 2019 pubs come up without accents:  "Otavio" and "Scholler".  I've done eveything as suggested (best as I can tell).  I suspect it is in my bib file?  Thanks for any help.