0
Not a bug

If you write in Spanish and use \'{a} or á, BibBase does not work fine.

vjerez 8 years ago updated by Jens Claßen 4 years ago 6

If you write in Spanish and use \'{a} or á, BibBase does not work fine.

Answer

Answer
Not a bug

Can you point me to a bibtex file with which you are having this problem? This should work. What is the error you are getting?

Thanks.



Under review

Can you point me to a bibtex file with which you are having this problem? This should work. What is the error you are getting?

Thanks.


I am so sorry, BibBase works fine, the problem was that the file was not really in the utf-8 encoding, I change the encoding to utf-8 and it works.


     Thank you very much for your answer  :).



Answer
Not a bug

Can you point me to a bibtex file with which you are having this problem? This should work. What is the error you are getting?

Thanks.



I am experiencing a similar problem with the German special letter 'ß', encoded as '{\ss}' in LaTeX, which is displayed as '\ss' by BibBase (e.g. author name 'Cla{\ss}en" is shown as 'Cla\ssen' instead of 'Claßen'). Umlauts ('ä','ö','ü', encoded as '{\"a}' etc.) work fine. My BibTeX is in UTF-8 as far as I can see: https://kbsg.rwth-aachen.de/~classen/jclassen.bib

Hallo Jens,


Thanks for reporting this! This turned out to be caused by a typo in our latex-to-unicode translator. It's fixed now:

http://bibbase.org/show?bib=https%3A%2F%2Fkbsg.rwth-aachen.de%2F~classen%2Fjclassen.bib&msg=embed


Best,

Christian