0
Answered

Embed not working in Chrome. Works in safari/FF

Saad Bhamla 7 years ago updated by Christian Fritz 7 years ago 5
I have incorporated bibbase on our website (https://web.stanford.edu/group/fullergroup/cgi-bin...,
but the bib base does NOT show up in chrome (only in safari and FF).

Is it because of the iframe being embedded with http, but the website is https?
Under review
Yes, that's exactly right. If you look into the developer console you'll see this error:

[blocked] The page at 'https://web.stanford.edu/group/fullergroup/cgi-bin...' was loaded over HTTPS, but ran insecure content from 'http://bibbase.org/show?bib=https%3A%2F%2Fweb.stan... this content should also be loaded over HTTPS.

Would embedding via PHP or CGI be an option. There are several benefits to those methods. This error would go away, but also you would wage better on SEO (search engine optimization) of your papers. It seems that you are already using cgi to render the page, so perhaps that method would be better suited? (see the second option for embedding on http://bibbase.org/help; you may be able to just use the CGI code within http://bibbase.org/help/bibbase_proxy2.cgi). Let me know if you need any help with that.

-- Christian

Christian, Thanks for the speedy reply.

Unfortunately, I don't have experience with executing CGI/PHP scripts from wordpress. 
The method you outlined may require additional steps to incorporate in wordpress, which are not obvious to me.

Does bibbase support HTTPS?

Saad
BibBase doesn't currently support HTTPS, but support is planned. If this is critical to you, I can see whether it can be prioritized. I noticed that there is also an HTTP version of your site, which works well (http://web.stanford.edu/group/fullergroup/cgi-bin/fullerlabsite/?page_id=301). Do you need HTTPS for your site or is most of the traffic going to come over HTTP? It's a little atypical for publication pages to use encryption (HTTPS), because there is nothing confidential about them. But your constraints might be slightly different, so please let me know.

Thanks,
-- Christian
Christian,
Fantastic. That worked out. I just changed the entire website to http.

Thanks again!
Saad
Answered
You're very welcome. Glad that works.

-- Christian